last sync: 2020-Sep-24 14:01:31 UTC

Azure Policy Initiative

[Deprecated]: Audit Windows VMs that do not have the specified Windows PowerShell modules installed

Initiative DisplayName [Deprecated]: Audit Windows VMs that do not have the specified Windows PowerShell modules installed
Initiative Id c980fd64-c67f-49a6-a8a8-e57661150802
Initiative Category Guest Configuration
Initiative Description This initiative deploys the policy requirements and audits Windows virtual machines that do not have the specified Windows PowerShell modules installed. For more information on Guest Configuration policies, please visit https://aka.ms/gcpol
Initiative Type BuiltIn
Initiative Changes
Date/Time (UTC ymd) (i) Change(s)
2020-08-28 14:17:28 change DisplayName Name change: 'Audit Windows VMs that do not have the specified Windows PowerShell modules installed' to '[Deprecated]: Audit Windows VMs that do not have the specified Windows PowerShell modules installed'
Initiative Policies count Total Policies: 2
Builtin Policies: 2/2
Static Policies: 0/2
Initiative Policies
Policy DisplayName Policy Id
[Deprecated]: Show audit results from Windows VMs that do not have the specified Windows PowerShell modules installed 16f9b37c-4408-4c30-bc17-254958f2e2d6
[Deprecated]: Deploy prerequisites to audit Windows VMs that do not have the specified Windows PowerShell modules installed 90ba2ee7-4ca8-4673-84d1-c851c50d3baf
Initiative Rule
{
  "properties": {
  "displayName": "[Deprecated]: Audit Windows VMs that do not have the specified Windows PowerShell modules installed",
    "policyType": "BuiltIn",
    "description": "This initiative deploys the policy requirements and audits Windows virtual machines that do not have the specified Windows PowerShell modules installed. For more information on Guest Configuration policies, please visit https://aka.ms/gcpol",
    "metadata": {
      "version": "1.0.0-deprecated",
      "category": "Guest Configuration",
      "deprecated": true
    },
    "parameters": {
      "Modules": {
        "type": "String",
        "metadata": {
        "displayName": "[Deprecated]: PowerShell Modules",
          "description": "A semicolon-separated list of the names of the PowerShell modules that should be installed. You may also specify a specific version of a module that should be installed by including a comma after the module name, followed by the desired version. e.g. PSDscResources; SqlServerDsc, 12.0.0.0; ComputerManagementDsc, 6.1.0.0"
        }
      }
    },
    "policyDefinitions": [
      {
        "policyDefinitionReferenceId": "Deploy_WindowsPowerShellModules",
        "policyDefinitionId": "/providers/Microsoft.Authorization/policyDefinitions/90ba2ee7-4ca8-4673-84d1-c851c50d3baf",
        "parameters": {
          "Modules": {
          "value": "[parameters('Modules')]"
          }
        }
      },
      {
        "policyDefinitionReferenceId": "Audit_WindowsPowerShellModules",
        "policyDefinitionId": "/providers/Microsoft.Authorization/policyDefinitions/16f9b37c-4408-4c30-bc17-254958f2e2d6"
      }
    ]
  },
  "id": "/providers/Microsoft.Authorization/policySetDefinitions/c980fd64-c67f-49a6-a8a8-e57661150802",
  "type": "Microsoft.Authorization/policySetDefinitions",
  "name": "c980fd64-c67f-49a6-a8a8-e57661150802"
}