last sync: 2024-Jul-17 18:20:29 UTC

[Deprecated]: Azure PostgreSQL flexible server should have Azure Active Directory Only Authentication enabled

Azure BuiltIn Policy definition

Source Azure Portal
Display name [Deprecated]: Azure PostgreSQL flexible server should have Azure Active Directory Only Authentication enabled
Id e27a6dfc-883f-4f9e-97cc-a819fe702400
Version 1.0.0-deprecated
Details on versioning
Category SQL
Microsoft Learn
Description This policy is deprecated because it uses unsupported api. Instead of continuing to use this policy, we recommend you instead assign this replacement policy with policy ID b4dec045-250a-48c2-b5cc-e0c4eec8b5b4. Learn more about policy definition deprecation at aka.ms/policydefdeprecation
Mode Indexed
Type BuiltIn
Preview False
Deprecated True
Reference Reference to 1 related Policy definition (taken from description)
A Microsoft Entra administrator should be provisioned for PostgreSQL servers (b4dec045-250a-48c2-b5cc-e0c4eec8b5b4)
Effect Default
Disabled
Allowed
AuditIfNotExists, Disabled
RBAC role(s) none
Rule aliases THEN-ExistenceCondition (1)
Alias Namespace ResourceType Path PathIsDefault DefaultPath Modifiable
Microsoft.DBforPostgreSQL/flexibleServers/configurations/value Microsoft.DBforPostgreSQL flexibleServers/configurations properties.value True False
Rule resource types IF (1)
Microsoft.DBforPostgreSQL/flexibleServers
Compliance Not a Compliance control
Initiatives usage none
History
Date/Time (UTC ymd) (i) Change type Change detail
2023-05-16 17:42:35 change Version remains equal, new suffix: deprecated (1.0.0 > 1.0.0-deprecated)
2023-05-01 17:41:52 add e27a6dfc-883f-4f9e-97cc-a819fe702400
JSON compare
compare mode: version left: version right:
JSON
api-version=2021-06-01
EPAC